# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?<!\d)(?:0?[1-9]|1[0-2])(?::[0-5]\d)?\p{Pd}(?:0?[1-9]|1[0-2])(?::[0-5]\d)?[ap]m\b"
test_str = ("bla bla 1:30-2pm bla bla 5-6:30am some text 1-2:15am\n"
"bla bla 1:30-2pm bla bla 5:23—6:30am some text 1—2:15am")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.