import Foundation
let pattern = #"(?i)(?<!\d)(?:0?[1-9]|1[0-2])(?::[0-5]\d)?\p{Pd}(?:0?[1-9]|1[0-2])(?::[0-5]\d)?[ap]m\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bla bla 1:30-2pm bla bla 5-6:30am some text 1-2:15am
bla bla 1:30-2pm bla bla 5:23—6:30am some text 1—2:15am
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)