$re = '/(?i)(?<!\d)(?:0?[1-9]|1[0-2])(?::[0-5]\d)?\p{Pd}(?:0?[1-9]|1[0-2])(?::[0-5]\d)?[ap]m\b/m';
$str = 'bla bla 1:30-2pm bla bla 5-6:30am some text 1-2:15am
bla bla 1:30-2pm bla bla 5:23—6:30am some text 1—2:15am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);