using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\D(?=[^(]*\))|\)\s*)";
string substitution = @"";
string input = @"hello (a1b2c3) (abc)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}