use strict;
my $str = 'hello (a1b2c3) (abc)';
my $regex = qr~(?:\D(?=[^(]*\))|\)\s*)~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";