const regex = new RegExp('(?:\\D(?=[^(]*\\))|\\)\\s*)', 'gm')
const str = `hello (a1b2c3) (abc)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);