$re = '~(?:\D(?=[^(]*\))|\)\s*)~m';
$str = 'hello (a1b2c3) (abc)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;