#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<loc>(.+)<\/loc>.*2020-08-06"
Local $sString = "<?xml version='1.0' encoding='UTF-8'?><urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">" & @CRLF & _
"<url><loc>https://google.com/2020/08/this1.html</loc><lastmod>2020-08-06T11:30:55Z</lastmod></url>" & @CRLF & _
"<url><loc>https://google.com/2020/08/this2.html</loc><lastmod>2020-08-05T11:30:06Z</lastmod></url>" & @CRLF & _
"<url><loc>https://google.com/2020/08/this3.html</loc><lastmod>2020-08-06T11:29:25Z</lastmod></url>" & @CRLF & _
"</lastmod></url></urlset>"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)