using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<loc>(.+)<\/loc>.*2020-08-06";
string substitution = @"\1";
string input = @"<?xml version='1.0' encoding='UTF-8'?><urlset xmlns=""http://www.sitemaps.org/schemas/sitemap/0.9"">
<url><loc>https://google.com/2020/08/this1.html</loc><lastmod>2020-08-06T11:30:55Z</lastmod></url>
<url><loc>https://google.com/2020/08/this2.html</loc><lastmod>2020-08-05T11:30:06Z</lastmod></url>
<url><loc>https://google.com/2020/08/this3.html</loc><lastmod>2020-08-06T11:29:25Z</lastmod></url>
</lastmod></url></urlset>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}