package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<loc>(.+)<\/loc>.*2020-08-06`)
var str = `<?xml version='1.0' encoding='UTF-8'?><urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
<url><loc>https://google.com/2020/08/this1.html</loc><lastmod>2020-08-06T11:30:55Z</lastmod></url>
<url><loc>https://google.com/2020/08/this2.html</loc><lastmod>2020-08-05T11:30:06Z</lastmod></url>
<url><loc>https://google.com/2020/08/this3.html</loc><lastmod>2020-08-06T11:29:25Z</lastmod></url>
</lastmod></url></urlset>`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}