const regex = /(?<!\S)REAL(?!\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)REAL(?!\\w)', 'gm')
const str = `REAL Internet es la red de comunicación REAL de computaREALdoras más grande del REALmundo.
Internet tiene muchas redes domésticas, académicas, comerciales y gubernamentales más pequeñas,
que en REAL conjunto transportanREAL muchos tipos diferentes de informaREALción.
Internet REAL fue desarrollado en los Estados Unidos por la REAL Agencia de Proyectos de Investigación Avanzada (DARPA)
del Departamento REAL de Defensa de losREAL Estados Unidos.
InterREALnet se conectó por primera vez en octubre de 1969 y se llamó REAL ARPANET.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}