use strict;
my $str = 'REAL Internet es la red de comunicación REAL de computaREALdoras más grande del REALmundo.
Internet tiene muchas redes domésticas, académicas, comerciales y gubernamentales más pequeñas,
que en REAL conjunto transportanREAL muchos tipos diferentes de informaREALción.
Internet REAL fue desarrollado en los Estados Unidos por la REAL Agencia de Proyectos de Investigación Avanzada (DARPA)
del Departamento REAL de Defensa de losREAL Estados Unidos.
InterREALnet se conectó por primera vez en octubre de 1969 y se llamó REAL ARPANET.';
my $regex = qr/(?<!\S)REAL(?!\w)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}