import re
regex = re.compile(r"(?<!\S)REAL(?!\w)", flags=re.MULTILINE)
test_str = ("REAL Internet es la red de comunicación REAL de computaREALdoras más grande del REALmundo.\n"
"Internet tiene muchas redes domésticas, académicas, comerciales y gubernamentales más pequeñas, \n"
"que en REAL conjunto transportanREAL muchos tipos diferentes de informaREALción.\n\n"
"Internet REAL fue desarrollado en los Estados Unidos por la REAL Agencia de Proyectos de Investigación Avanzada (DARPA)\n"
"del Departamento REAL de Defensa de losREAL Estados Unidos. \n\n"
"InterREALnet se conectó por primera vez en octubre de 1969 y se llamó REAL ARPANET.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")