$re = '/(?<!\S)REAL(?!\w)/m';
$str = 'REAL Internet es la red de comunicación REAL de computaREALdoras más grande del REALmundo.
Internet tiene muchas redes domésticas, académicas, comerciales y gubernamentales más pequeñas,
que en REAL conjunto transportanREAL muchos tipos diferentes de informaREALción.
Internet REAL fue desarrollado en los Estados Unidos por la REAL Agencia de Proyectos de Investigación Avanzada (DARPA)
del Departamento REAL de Defensa de losREAL Estados Unidos.
InterREALnet se conectó por primera vez en octubre de 1969 y se llamó REAL ARPANET.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);