using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[?&]param(?:[&=]|$)";
string input = @"http://example.com?param
http://example.com?param=123
http://example.com?param&another";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}