$re = '/[?&]param(?:[&=]|$)/m';
$str = 'http://example.com?param
http://example.com?param=123
http://example.com?param&another';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);