package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[?&]param(?:[&=]|$)`)
var str = `http://example.com?param
http://example.com?param=123
http://example.com?param&another`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}