re = /[?&]param(?:[&=]|$)/m
str = 'http://example.com?param
http://example.com?param=123
http://example.com?param&another'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end