#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<modifiers>\/(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<flipx>\-)?(?<width>\d+)x(?<flipy>\-)?(?<height>\d+))?\/?(?<filters>filters\:([^,\/]+,)*(?:format\((?<format>\w+)\))?[^\/]*\/?)?)?(?<id>\/f\/.+)$" & @CRLF & _
""
Local $sString = "/100x100:450x350/200x200/filters:grayscale()/f/39898/1000x600/d962430746/demo-image-human.jpeg" & @CRLF & _
"/600x130/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg" & @CRLF & _
"/-230x230/filters:rotate(90)/f/39898/1000x600/d962430746/demo-image-human.jpeg" & @CRLF & _
"/f/39898/3310x2192/e4ec08624e/demo-image.jpeg" & @CRLF & _
"/200x0/filters:format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg" & @CRLF & _
"/f/39898/3310x2192/e4ec08624e/demo-image.jpeg" & @CRLF & _
"/200x0/filters:something(),format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")