$re = '/^(?<modifiers>\/(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<flipx>\-)?(?<width>\d+)x(?<flipy>\-)?(?<height>\d+))?\/?(?<filters>filters\:([^,\/]+,)*(?:format\((?<format>\w+)\))?[^\/]*\/?)?)?(?<id>\/f\/.+)$
/m';
$str = '/100x100:450x350/200x200/filters:grayscale()/f/39898/1000x600/d962430746/demo-image-human.jpeg
/600x130/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg
/-230x230/filters:rotate(90)/f/39898/1000x600/d962430746/demo-image-human.jpeg
/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/200x0/filters:format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/200x0/filters:something(),format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);