// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<modifiers>\/(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<flipx>\-)?(?<width>\d+)x(?<flipy>\-)?(?<height>\d+))?\/?(?<filters>filters\:([^,\/]+,)*(?:format\((?<format>\w+)\))?[^\/]*\/?)?)?(?<id>\/f\/.+)$
").unwrap();
let string = "/100x100:450x350/200x200/filters:grayscale()/f/39898/1000x600/d962430746/demo-image-human.jpeg
/600x130/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg
/-230x230/filters:rotate(90)/f/39898/1000x600/d962430746/demo-image-human.jpeg
/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/200x0/filters:format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/200x0/filters:something(),format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}