use strict;
my $str = '/100x100:450x350/200x200/filters:grayscale()/f/39898/1000x600/d962430746/demo-image-human.jpeg
/600x130/f/39898/2250x1500/c15735a73c/demo-image-human.jpeg
/-230x230/filters:rotate(90)/f/39898/1000x600/d962430746/demo-image-human.jpeg
/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/200x0/filters:format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
/200x0/filters:something(),format(png)/f/39898/3310x2192/e4ec08624e/demo-image.jpeg
';
my $regex = qr/^(?<modifiers>\/(?<crop>\d+x\d+:\d+x\d+)?\/?(?<resize>(?<flipx>\-)?(?<width>\d+)x(?<flipy>\-)?(?<height>\d+))?\/?(?<filters>filters\:([^,\/]+,)*(?:format\((?<format>\w+)\))?[^\/]*\/?)?)?(?<id>\/f\/.+)$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}