#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^[A-zÀ-ÿ ]*\1*,(?:\s)(\w*,\s)(CEP (\d{5}-\d{3}))"
Local $sString = "Rua das Flores, 123, CEP 60321-105" & @CRLF & _
"Avenida Brasil, 456A, CEP 16945-017" & @CRLF & _
"Travessa dos Santos, 101, CEP 12345-678" & @CRLF & _
"Rua Catarina, 243, CEP 25437-987" & @CRLF & _
"Rua Sâo Pedro, 243, cep 25437-987" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\^[A-Za-z ]*\1*,(?:\s)(\w*,\s)(CEP (\d{5}-\d{3}))\"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)