import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-zÀ-ÿ ]*\\1*,(?:\\s)(\\w*,\\s)(CEP (\\d{5}-\\d{3}))";
final String string = "Rua das Flores, 123, CEP 60321-105\n"
+ "Avenida Brasil, 456A, CEP 16945-017\n"
+ "Travessa dos Santos, 101, CEP 12345-678\n"
+ "Rua Catarina, 243, CEP 25437-987\n"
+ "Rua Sâo Pedro, 243, cep 25437-987\n\n\n";
final String subst = "\\^[A-Za-z ]*\\1*,(?:\\s)(\\w*,\\s)(CEP (\\d{5}-\\d{3}))\\";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}