using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-zÀ-ÿ ]*\1*,(?:\s)(\w*,\s)(CEP (\d{5}-\d{3}))";
string substitution = @"\^[A-Za-z ]*\1*,(?:\s)(\w*,\s)(CEP (\d{5}-\d{3}))\";
string input = @"Rua das Flores, 123, CEP 60321-105
Avenida Brasil, 456A, CEP 16945-017
Travessa dos Santos, 101, CEP 12345-678
Rua Catarina, 243, CEP 25437-987
Rua Sâo Pedro, 243, cep 25437-987
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}