using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*([,\h])[,\h]*";
string substitution = @"$1";
string input = @"first , second ,, , , third, ,fourth suffix ,, more";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}