const regex = /\h*([,\h])[,\h]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*([,\\h])[,\\h]*', 'gm')
const str = `first , second ,, , , third, ,fourth suffix ,, more`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);