$re = '/\h*([,\h])[,\h]*/m';
$str = 'first , second ,, , , third, ,fourth suffix ,, more';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;