use strict;
my $str = 'first , second ,, , , third, ,fourth suffix ,, more';
my $regex = qr/\h*([,\h])[,\h]*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";