#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)<span>(.*)</span><div>(.*)</div><div data-tid="messageBodyContainer">"
Local $sString = "<span>[10/6 8:23 PM] </span><span>Dalon, Thierry</span><div>Let's Connect presentation available</div><div data-tid="messageBodyContainer">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")