re = /<span>(.*)<\/span><div>(.*)<\/div><div data-tid="messageBodyContainer">/m
str = '<span>[10/6 8:23 PM] </span><span>Dalon, Thierry</span><div>Let\'s Connect presentation available</div><div data-tid="messageBodyContainer">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end