using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span>(.*)</span><div>(.*)</div><div data-tid=""messageBodyContainer"">";
string input = @"<span>[10/6 8:23 PM] </span><span>Dalon, Thierry</span><div>Let's Connect presentation available</div><div data-tid=""messageBodyContainer"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}