package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)<span>(.*)</span><div>(.*)</div><div data-tid="messageBodyContainer">`)
var str = `<span>[10/6 8:23 PM] </span><span>Dalon, Thierry</span><div>Let's Connect presentation available</div><div data-tid="messageBodyContainer">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}