#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=@20).*?(?=@50|\.|F5|AF5)"
Local $sString = "@20dibur@50 sdfgghh." & @CRLF & _
"@20dibur nosaf. end here@50." & @CRLF & _
"@20dibur fsrtt sdfsf@50 sdfgghh." & @CRLF & _
"@20dibur fsrtt F5 sdfsf@50 sdfgghh." & @CRLF & _
"@20dibur fsrtt AF5 sdfsf@50 sdfgghh." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")