using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=@20).*?(?=@50|\.|F5|AF5)";
string input = @"@20dibur@50 sdfgghh.
@20dibur nosaf. end here@50.
@20dibur fsrtt sdfsf@50 sdfgghh.
@20dibur fsrtt F5 sdfsf@50 sdfgghh.
@20dibur fsrtt AF5 sdfsf@50 sdfgghh.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}