#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)\([^(]*\((.+)\)[^)]*\)"
Local $sString = "hello ((" & @CRLF & _
"" & @CRLF & _
"(alpha123_4rf)" & @CRLF & _
"45beta_Frank))" & @CRLF & _
"Red5Great_Sam_Fun"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")