$re = '/(?s)\([^(]*\((.+)\)[^)]*\)/m';
$str = 'hello ((
(alpha123_4rf)
45beta_Frank))
Red5Great_Sam_Fun';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);