package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\([^(]*\((.+)\)[^)]*\)`)
var str = `hello ((
(alpha123_4rf)
45beta_Frank))
Red5Great_Sam_Fun`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}