#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<Root>file\:\/\/\/(?:[A-Za-z]+):(?:\/|\\)|https\:\/\/)(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:pdf)))$"
Local $sString = "file:///D:/Documents/My%20Documents/T09_27jun-17jul_V_Fro.pdf" & @CRLF & _
"" & @CRLF & _
"file:///z:/Documents/My%20Documents/pdfs/eggs,%20milk,%20fruit.pdf" & @CRLF & _
"" & @CRLF & _
"file:///zz:/Documents/My%20Documents/example.folder/icebreaker.pdf" & @CRLF & _
"" & @CRLF & _
"file:///abv:/program%20shmogram%20(x86)/CoolTheVideoGameTheMovie/lewd.mods/uwuDialogueforFemales.pdf" & @CRLF & _
"" & @CRLF & _
"file:///h:/Documents/My%20Documents/example.folder/New%20folder/ExamplE%20folder%203/very_cool_kanye.pdf" & @CRLF & _
"https://www.samsclub.com/savings/20230626/T09_27jun-17jul_V_Fro.pdf" & @CRLF & _
"" & @CRLF & _
"https://whatkindofprefixisthis.RobertTheWebsite.io/AboutUs/Who-Da-frick_IS_This-Bobert-anyways.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")