const regex = /^(?P<Root>file\:\/\/\/(?:[A-Za-z]+):(?:\/|\\)|https\:\/\/)(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:pdf)))$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<Root>file\\:\\\/\\\/\\\/(?:[A-Za-z]+):(?:\\\/|\\\\)|https\\:\\\/\\\/)(?P<Relative>(?:(?:[^<>:"\\\/\\\\|?*\\n])+(?:\\\/|\\\\))+)(?P<File>(?:[^<>:"\\\/\\\\|?*\\n]+)(?:\\.(?:pdf)))$', 'mg')
const str = `file:///D:/Documents/My%20Documents/T09_27jun-17jul_V_Fro.pdf
file:///z:/Documents/My%20Documents/pdfs/eggs,%20milk,%20fruit.pdf
file:///zz:/Documents/My%20Documents/example.folder/icebreaker.pdf
file:///abv:/program%20shmogram%20(x86)/CoolTheVideoGameTheMovie/lewd.mods/uwuDialogueforFemales.pdf
file:///h:/Documents/My%20Documents/example.folder/New%20folder/ExamplE%20folder%203/very_cool_kanye.pdf
https://www.samsclub.com/savings/20230626/T09_27jun-17jul_V_Fro.pdf
https://whatkindofprefixisthis.RobertTheWebsite.io/AboutUs/Who-Da-frick_IS_This-Bobert-anyways.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}