import Foundation
let pattern = #"^(?P<Root>file\:\/\/\/(?:[A-Za-z]+):(?:\/|\\)|https\:\/\/)(?P<Relative>(?:(?:[^<>:"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:"\/\\|?*\n]+)(?:\.(?:pdf)))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
file:///D:/Documents/My%20Documents/T09_27jun-17jul_V_Fro.pdf
file:///z:/Documents/My%20Documents/pdfs/eggs,%20milk,%20fruit.pdf
file:///zz:/Documents/My%20Documents/example.folder/icebreaker.pdf
file:///abv:/program%20shmogram%20(x86)/CoolTheVideoGameTheMovie/lewd.mods/uwuDialogueforFemales.pdf
file:///h:/Documents/My%20Documents/example.folder/New%20folder/ExamplE%20folder%203/very_cool_kanye.pdf
https://www.samsclub.com/savings/20230626/T09_27jun-17jul_V_Fro.pdf
https://whatkindofprefixisthis.RobertTheWebsite.io/AboutUs/Who-Da-frick_IS_This-Bobert-anyways.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)