# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<Root>file\:\/\/\/(?:[A-Za-z]+):(?:\/|\\)|https\:\/\/)(?P<Relative>(?:(?:[^<>:\"\/\\|?*\n])+(?:\/|\\))+)(?P<File>(?:[^<>:\"\/\\|?*\n]+)(?:\.(?:pdf)))$"
test_str = ("file:///D:/Documents/My%20Documents/T09_27jun-17jul_V_Fro.pdf\n\n"
"file:///z:/Documents/My%20Documents/pdfs/eggs,%20milk,%20fruit.pdf\n\n"
"file:///zz:/Documents/My%20Documents/example.folder/icebreaker.pdf\n\n"
"file:///abv:/program%20shmogram%20(x86)/CoolTheVideoGameTheMovie/lewd.mods/uwuDialogueforFemales.pdf\n\n"
"file:///h:/Documents/My%20Documents/example.folder/New%20folder/ExamplE%20folder%203/very_cool_kanye.pdf\n"
"https://www.samsclub.com/savings/20230626/T09_27jun-17jul_V_Fro.pdf\n\n"
"https://whatkindofprefixisthis.RobertTheWebsite.io/AboutUs/Who-Da-frick_IS_This-Bobert-anyways.pdf")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.