using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-)|[.,](?=[^.,\n]*[.,](?!$))|[,.]+$|[^0-9.,\n]+";
string substitution = @"$1";
string input = @"10.23.45.
10.23.45
123 ->
123
123.45 ->
123.45
123,45 ->
123,45
-123 ->
-123
-123.45 ->
-123.45
-123,45 ->
-123,45
--123.45 ->
-123.45
--123,45 ->
-123,45
a ->
-a ->
-
a123 ->
123
-a123 ->
-123
a123.45 ->
123.45
-a123.45 ->
-123.45
a123.b45 ->
123.45
-a123.b45 ->
-123.45
123.-34 ->
123.34
-123.-34 ->
-123.34
--123.-34 ->
-123.34";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}