const regex = /^(-)|[.,](?=[^.,\n]*[.,](?!$))|[,.]+$|[^0-9.,\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-)|[.,](?=[^.,\\n]*[.,](?!$))|[,.]+$|[^0-9.,\\n]+', 'gm')
const str = `10.23.45.
10.23.45
123 ->
123
123.45 ->
123.45
123,45 ->
123,45
-123 ->
-123
-123.45 ->
-123.45
-123,45 ->
-123,45
--123.45 ->
-123.45
--123,45 ->
-123,45
a ->
-a ->
-
a123 ->
123
-a123 ->
-123
a123.45 ->
123.45
-a123.45 ->
-123.45
a123.b45 ->
123.45
-a123.b45 ->
-123.45
123.-34 ->
123.34
-123.-34 ->
-123.34
--123.-34 ->
-123.34`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);