$re = '/^(-)|[.,](?=[^.,\n]*[.,](?!$))|[,.]+$|[^0-9.,\n]+/m';
$str = '10.23.45.
10.23.45
123 ->
123
123.45 ->
123.45
123,45 ->
123,45
-123 ->
-123
-123.45 ->
-123.45
-123,45 ->
-123,45
--123.45 ->
-123.45
--123,45 ->
-123,45
a ->
-a ->
-
a123 ->
123
-a123 ->
-123
a123.45 ->
123.45
-a123.45 ->
-123.45
a123.b45 ->
123.45
-a123.b45 ->
-123.45
123.-34 ->
123.34
-123.-34 ->
-123.34
--123.-34 ->
-123.34';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;