import re
regex = re.compile(r"^(-)|[.,](?=[^.,\n]*[.,](?!$))|[,.]+$|[^0-9.,\n]+", flags=re.MULTILINE)
test_str = ("10.23.45.\n"
"10.23.45\n"
"123 -> \n"
"123\n"
"123.45 -> \n"
"123.45\n"
"123,45 -> \n"
"123,45\n"
"-123 -> \n"
"-123\n"
"-123.45 -> \n"
"-123.45\n"
"-123,45 ->\n"
"-123,45\n"
"--123.45 ->\n"
"-123.45\n"
"--123,45 -> \n"
"-123,45\n"
"a -> \n\n"
"-a -> \n"
"-\n"
"a123 -> \n"
"123\n"
"-a123 -> \n"
"-123\n"
"a123.45 -> \n"
"123.45\n"
"-a123.45 ->\n"
"-123.45\n"
"a123.b45 -> \n"
"123.45\n"
"-a123.b45 -> \n"
"-123.45\n"
"123.-34 -> \n"
"123.34\n"
"-123.-34 -> \n"
"-123.34\n"
"--123.-34 -> \n"
"-123.34")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)