using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?:\G(?!^)|\bworld\b).*?\K\bhello\b";
string input = @"blah blah blah
hello
blah blah blah
class=""world""
blah blah blah
hello
blah blah
hello
blah blah blah
hello
blah blah blah";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}