const regex = /(?s)(?:\G(?!^)|\bworld\b).*?\K\bhello\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?:\\G(?!^)|\\bworld\\b).*?\\K\\bhello\\b', 'g')
const str = `blah blah blah
hello
blah blah blah
class="world"
blah blah blah
hello
blah blah
hello
blah blah blah
hello
blah blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}