import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:\\G(?!^)|\\bworld\\b).*?\\K\\bhello\\b";
final String string = "blah blah blah\n"
+ "hello\n"
+ "blah blah blah\n"
+ "class=\"world\" \n"
+ "blah blah blah\n"
+ "hello \n"
+ "blah blah\n"
+ "hello\n"
+ "blah blah blah\n"
+ "hello\n"
+ "blah blah blah";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}