$re = '/(?s)(?:\G(?!^)|\bworld\b).*?\K\bhello\b/';
$str = 'blah blah blah
hello
blah blah blah
class="world"
blah blah blah
hello
blah blah
hello
blah blah blah
hello
blah blah blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);